Frigate 0.11.0 → 0.12.0
2 versions, 1 with breaking changes, 0 required stops
Version by version, oldest first
0.11.1: no action items (1 version)
0.12.0 2023-04-08
Breaking
- We are no longer pushing images to Dockerhub. All docker builds will be published to github container registry instead. The new image location for stable is
ghcr.io/blakeblackshear/frigate:stable - If using the Frigate-HomeAssistant Integration it will need to be updated to 4.0.0 to avoid breaking changes with Frigate 0.12
- Changes have been made to the database, a backup of the database will need to be made before updating if you want to roll-back.
- Some deployment approaches are overwriting the PATH environment value to an old value. If you see errors like
./run: line 7: exec: nginx: not found, then you need to stop overriding your PATH. This happens with both Proxmox LXC and Portainer (https://github.com/blakeblackshear/frigate/issues/3223)Otherwise the database will need to be deleted to roll-back successfully. - Some deployment approaches are overwriting the command docker value giving errors like
[Errno 98] Address already in uswhich need to be set back to default to work https://github.com/blakeblackshear/frigate/issues/5444 - The shm storage requirements have changed for 0.12, they will likely need to be recalculated and adjusted in the config, see the docs for how to calculate this new value. NOTE: This does not apply to addon users which are unable to configure this value.
- More config validation checks have been added, it is possible that Frigate will fail to start due to an error that has been caught, the error will need to be fixed before frigate can start.
- RTMP is now disabled by default and the role is not automatically added. It is highly recommend to move to the new RTSP streams via the bundled go2rtc.
- Changes have been made to the way recordings segments are stored, external scripts which access the recordings file structure directly may be broken.
Release notes from github.com/blakeblackshear/frigate/releases, checked 17 hours ago. Only text the vendor marks as breaking, or puts in a warning/caution/important note, is shown; read the full notes for anything else.